[Qt-creator] Clang Code model can not find libClang 3.6

Michael Jackson imikejackson at gmail.com
Mon Jun 22 16:01:52 CEST 2015


I am running on OS X 10.8.5 and there are a few problems that I have figured out. The first is that the library will not load. This is because the "@rpath" is incorrect on libClang.dylib. It should be @rpath/Plugins/libClang.dylib

Also, the rpath that is actually linked to is lib clang-3.6.dylib which throws everything off. Adding a few symlinks and moving the lib clang.dylib from plugins up one directory allowed OS X QtCreator to load the Clang Code model plugin but then QtCreator just "beach balled" and never ever responded again.

I also noticed that the Download as "OSX10.10" which implies that QtCreator ONLY works on OS X 10.10? Is this true going forward or just for these nightly snapshots?

Mike Jackson
BlueQuartz Software.

On Jun 22, 2015, at 3:25 AM, Ziller Eike <Eike.Ziller at theqtcompany.com> wrote:

>> On Jun 19, 2015, at 3:44 PM, Michael Jackson <imikejackson at gmail.com> wrote:
>> Just tried the QtCreator 3.5 Beta and tried to load the Clang code model and it says that it can not load libClang. Could someone remind me of the wiki page that has the instructions on how to get the Clang code model up and running?
> Luckily we haven’t released a 3.5 beta yet, and that the clang code model doesn’t work in the snapshots is a known issue which I’m currently trying to solve for the actual beta release :D
> Br, Eike
>> Thanks
>> Mike Jackson
>> BlueQuartz Software.
>> _______________________________________________
>> Qt-creator mailing list
>> Qt-creator at qt-project.org
>> http://lists.qt-project.org/mailman/listinfo/qt-creator
> -- 
> Eike Ziller, Senior Software Engineer - The Qt Company GmbH
> The Qt Company GmbH, Rudower Chaussee 13, D-12489 Berlin
> Geschäftsführer: Mika Pälsi, Juha Varelius, Tuula Haataja
> Sitz der Gesellschaft: Berlin, Registergericht: Amtsgericht Charlottenburg, HRB 144331 B

More information about the Qt-creator mailing list