[Qt-creator] Fwd: Re: run button disabled bug on FreeBSD

Ralf Nolden nolden at kde.org
Sun Jun 19 08:22:05 CEST 2016

Am Samstag, 18. Juni 2016, 15:57:05 schrieben Sie:
> Hi Ralf,
> Am 18.06.2016 10:57 schrieb "Ralf Nolden" <nolden at kde.org>:
> > Hi,
> > 
> > in https://blog.qt.io/blog/2016/06/08/qt-creator-4-0-1-released/
> > 
> > one of the last comments was that the run button is disabled
> > on 4.0.1 (I did the FreeBSD port so the user apparently installed it from
> > the FreeBSD packages). I can confirm this happening on FreeBSD 10.3 from
> > qtcreator 4.0 onward, 3.6.1 and before didn't have that problem.
> There apparently is a race condition somewhere that causes the qmake Parser
> to fail once and then there is no way to recover from that anymore.
> To verify whether you got the same problem: Please hover the disabled run
> button. If it says something along the line of "parsing failed", then you
> got that, too.
No, for me it says "Cannot run untitled10".

However, the debug run button is still active. Trying that, it gives me the 
output "no executable specified" which comes from 

qt-creator/src/plugins/debugger/debuggerruncontrol.cpp: 157.

I tried commenting out that and then on start, I get a dialog giving me 
"Starting executable failed: < path to qtcreator start dir (the bin in the 
builddir) >

The values that get questioned before that give "No executables specified are 
giving me:

m_engine->runParameters().startMode -->> 1
m_engine->runParameters().inferior.executable -->> ""
m_engine->runParameters().interpreter -->> ""

I hope that helps. However, I can't really find how the runnable.executable is 
set and why that fails for freebsd using clang.
> The fastest work-around is to open a .pro-file, modify that and save it.
> That re-enables the run button.
I saw your hint in the qtbugs that refer to similar issues and tried that 
already :) but that doesn't work for me. The problem stays the same.

> I was experimenting with the add file functionality on Friday, which is a
> way to trigger the broken run button according to bug reports I got. So far
> I tried adding 1000files on Linux (without problem) and on Windows (where
> the test takes too long and stops after about 200 files and several pop-ups
> about being out of disk space). But so far I could not trigger the broken
> run button.
> Any idea how to reproduce the issue is welcome! Maybe I should try building
> with gcc on Linux... if this is compiler dependent, then switching from
> clang (which I use most of the time) to gcc might trigger this.
Which would be the other way around I have it :)  
> Best Regards,
> Tobias

Kind regards,

Ralf Nolden
Kind regards,

Ralf Nolden

More information about the Qt-creator mailing list