[Qt-creator] Autocompletion of 0.0 to 0->0 in QtCreator 4.x series

Mike Jackson imikejackson at gmail.com
Wed Jun 22 20:10:37 CEST 2016

Murphy, Sean wrote:
>>>> At what point is the bug that autocompletes 0.0 to 0->0 going to be
>>>> fixed? Just curious? Those of us writing scientific codes where we
>>>> initialize our floats/doubles to actual values are really effected by
>>>> this bug.
>>> What version(s) are you seeing this in? I'm using Qt Creator 4.0.0,
>>> based on 5.6.0 on Windows and I don't see the behavior you're describing.
>>> If I type "0." the period stays a period, and then I can type the next 0 and
>>> still get "0.0".
>>> Sean
>> 4.0.1, 4.0.2, 4.0.3 all nightlies from download.qt.io. Running on OS X
>> 10.10.4 with the latest Xcode for that OS.
>> Maybe it is how I have a settings configured?
> Maybe? I just switched over to OS X, downloaded the official Qt 5.7.0 with
> Qt 4.0.2, opened an existing project I had, and typed "0." and it was NOT
> autocorrected to "0->". Is there another step you're doing that I'm missing?
> I also tried with a new project (Qt Widget Application) with the same result.
> OS X version 10.11.5, Xcode 7.3.1 if that helps.
> Sean

"Autocomplete common prefix" was enabled and that apparently is the 
problem. I'm not sure what that option actually does so I'll just turn 
it off and go about my business.

Michael A. Jackson
BlueQuartz Software, LLC
[e]: mike.jackson at bluequartz.net

More information about the Qt-creator mailing list