[Qt-creator] Autocompletion of 0.0 to 0->0 in QtCreator 4.x series

Eike Ziller Eike.Ziller at qt.io
Thu Jun 23 10:36:28 CEST 2016

> On Jun 22, 2016, at 20:05, Murphy, Sean <smurphy at walbro.com> wrote:
>>>> At what point is the bug that autocompletes 0.0 to 0->0 going to be
>>>> fixed? Just curious? Those of us writing scientific codes where we
>>>> initialize our floats/doubles to actual values are really effected by
>>>> this bug.
>>> What version(s) are you seeing this in? I'm using Qt Creator 4.0.0,
>>> based on 5.6.0 on Windows and I don't see the behavior you're describing.
>>> If I type "0." the period stays a period, and then I can type the next 0 and
>>> still get "0.0".
>>> Sean
>> 4.0.1, 4.0.2, 4.0.3 all nightlies from download.qt.io. Running on OS X
>> 10.10.4 with the latest Xcode for that OS.
>> Maybe it is how I have a settings configured?
> Maybe? I just switched over to OS X, downloaded the official Qt 5.7.0 with 
> Qt 4.0.2, opened an existing project I had, and typed "0." and it was NOT
> autocorrected to "0->". Is there another step you're doing that I'm missing?
> I also tried with a new project (Qt Widget Application) with the same result.
> OS X version 10.11.5, Xcode 7.3.1 if that helps.

I think this only happens with the Clang code model, so you’d need to turn that on (About Plugins… > ClangCodeModel) to see the issue.

Br, Eike

Eike Ziller
Principal Software Engineer

The Qt Company GmbH
Rudower Chaussee 13
D-12489 Berlin
eike.ziller at qt.io
+123 45 6789012
Geschäftsführer: Mika Pälsi, Juha Varelius, Tuula Haataja
Sitz der Gesellschaft: Berlin, Registergericht: Amtsgericht Charlottenburg, HRB 144331 B

More information about the Qt-creator mailing list