[Qt-creator] QtCreator 4.3b1 background thread running?

Henry Skoglund fromqt at tungware.se
Thu Apr 13 12:13:38 CEST 2017


Excellent news that the Welcome page uses widgets, I should download the 
4.3 beta and try it!
And also remember to unlearn my "universal solution #1" :-) /Rgrds Henry

On 2017-04-13 11:34, Thomas Hartmann wrote:
> Hi,
>
> -noload Welcome is not required anymore, since the Welcome Page was reimplemented using widgets.
> An alternative to avoid OpenGL issues on Windows is "set QT_OPENGL=software".
> I cannot reproduce the issue on my Windows 10 setup.
>
> Kind Regards,
> Thomas Hartmann
>
> -----Urspr√ľngliche Nachricht-----
> Von: Qt-creator [mailto:qt-creator-bounces+thomas.hartmann=qt.io at qt-project.org] Im Auftrag von Henry Skoglund
> Gesendet: Thursday, April 13, 2017 11:28 AM
> An: qt-creator at qt-project.org; skobowsky at caos-gmbh.de
> Betreff: Re: [Qt-creator] QtCreator 4.3b1 background thread running?
>
> Hi, you could try starting Qt Creator from a CMD window (universal solution #1 for opengl problems) to see if the CPU consumption subsides:
>
> qtcreator -noload Welcome -noload QmlDesigner -noload QmlProfiler
>
> Rgrds Henry
>
> On 2017-04-13 11:20, Tilman Skobowsky wrote:
>> Hi,
>>
>> I just downloaded Qt-Creator 4.3.0 b1 for some testing.
>> What immediately struck me was the ongoing action in one thread that
>> consumes about half a CPU core's performance.
>> The stacktrace (taken with ProcessExplorer) is
>>
>> 0    ntdll.dll!ZwRequestWaitReplyPort+0xa
>> 1    dwmapi.dll!DwmSetWindowAttribute+0x1cc
>> 2    dwmapi.dll!DwmSetWindowAttribute+0x3d0
>> 3    dwmapi.dll!Ordinal132+0x97a
>> 4    dwmapi.dll!DwmSetWindowAttribute+0x2cc
>> 5    dwmapi.dll!DwmFlush+0x92
>> 6    ig75icd64.dll!DrvValidateVersion+0x139a
>> 7    kernel32.dll!BaseThreadInitThunk+0xd
>> 8    ntdll.dll!RtlUserThreadStart+0x21
>>
>> Checking on the web I found an entry on the Team Speak forum where
>> they observed the same issue but with a different Qt-based software.
>> As described there, I can kill the thread without noticing a real
>> problem when using Qt-Creator.
>>
>> I double checked this with both 32bit and 64bit. The problem occurrs
>> in both versions.
>> My machine runs Win7
>>
>> Any ideas?
>>
>> TIA
>> Tilman
>> _______________________________________________
>> Qt-creator mailing list
>> Qt-creator at qt-project.org
>> http://lists.qt-project.org/mailman/listinfo/qt-creator
>>
>
>
> _______________________________________________
> Qt-creator mailing list
> Qt-creator at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/qt-creator
>





More information about the Qt-creator mailing list