[Qt-creator] Android adb start --user

Orgad Shaneh orgads at gmail.com
Thu Feb 16 12:49:44 CET 2017

On Thu, Feb 16, 2017 at 1:07 PM, ekke <ekke at ekkes-corner.org> wrote:

> Orgad,
> thanks for the tip and help
> Tried Custom Run Configuration:
> Executable: adb
> Arguments: shell am start --user 10 -n my.package.name/org.qtproject.
> qt5.android.bindings.QtActivity
> WorkingDir: %{buildDir}
> Tried with or without checking the 'Run in terminal box'
> getting error:
> Cannot find the androiddeploy Json file.
> Error while building/deploying project my_project (kit: Android for
> armeabi-v7a (GCC 4.9, Qt 5.7.0))
> When executing step "Deploy to Android device"

That means it didn't reach the Run step, it fails on deploy. You can also
have a custom Deploy configuration, but I'm not sure what exactly is wrong
there, and what should be done instead...

- Orgad
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qt-creator/attachments/20170216/aa804912/attachment.html>

More information about the Qt-creator mailing list