[Qt-creator] 4.3 Beta with CMake Server Integration Feedback (II)

Mike Jackson imikejackson at gmail.com
Wed Jan 18 21:07:43 CET 2017

Sure, the project is at http://www.github.com/bluequartzsoftware/dream3d

there are dependencies on the following other repositories:

Those then depend on the following:

CMake, Boost, Eigen, HDF5, ITK, Qt5.6, TBB, Qwt. It takes a bit to get 
everything installed and compiled. We have tried several ways to 
compile/install all the dependent libraries such as Scripts and a CMake 
SuperBuild. There always seems to be some tweaking of the scripts to get 
everything compiled.

I just tried configuring with the source code for CMake 3.7.2 and I do 
not get any duplicate targets. Interesting. Maybe there is something 
"non-standard" in our use of CMake for the DREAM.3D project.

The http://www.github.com/bluequartzsoftware/SIMPL project is our "base" 
project and can be compiled by itself (but still needing the CMP repo 
and most of the other dependent libraries. This is a smaller project and 
there are only a few duplicates and some non-duplicate targets. Let me 
see if I can track down the issue on our end.

Glad to hear about the socket. I'll just make it standard to remove the 
socket file until the fixes are in.
Michael A. Jackson                 400 S. Pioneer Blvd
Owner, President                   Springboro, Ohio 45066
BlueQuartz Software, LLC           EMail: mike.jackson at bluequartz.net
Voice: 937-790-1601                Web: http://www.bluequartz.net
Fax: 937-746-0783

Tobias Hunger wrote:
> Hi Mike,
> On Wed, Jan 18, 2017 at 3:23 PM, Mike Jackson<imikejackson at gmail.com>  wrote:
>> Have been trying the nightly builds. Typically I need to delete the
>> CMakeLists.txt.user from my project directory to get a successful
>> configuration. The first time QtCreator tries to run cmake something exits
>> with error code -1.
> The only way the cmake server may exit with error code -1 is that the
> socket can not get created. I worked on that today, but the patches
> are still on gerrit.
> For now you could make sure to delete the socket in the build directory:-)
>> I try the configuration step again and things seem to
>> work. When change the executable to be run through the normal button on the
>> left side I get 3 "versions" of every target, for example, DREAM3D,
> Oh, I did not notice that yet. Can I download that project somewhere
> so I can try it? Maybe it is something in the CMakeLists.txt.
>> I have cmake 3.7.2 installed. This is on OS X 10.10.5 with Xcode 7.2.1
>> tooling.
>> Thanks for all the hard work on this. It looks like it is coming along
>> nicely and will be a great addition to QtCreator.
> Thank you for testing and providing feedback!
> Best Regards,
> Tobias

More information about the Qt-creator mailing list