[Qt-creator] Android debugging in Qt Creator 4.10.2

Robert Loehning Robert.Loehning at qt.io
Thu Jan 16 10:56:13 CET 2020

Am 16.01.20 um 10:01 schrieb Francesc Martinez:
> Hi all,
> I'm running a CMake project and I'm struggling to debug Android build with
> Qt Creator 4.10.2 and Qt 5.13.1. Everything works fine during building and
> deploying. But if I try to debug the build it just crashes with the message:
> LOGCAT: The command "/home/<user>/Android/Sdk/platform-tools/adb"
> terminated with exit code 1.
> adb: error: listener 'tcp:5039' not found
> I tried with API 21, 24 and 29. All of them fail.
> I tried with different Android devices: Nexus 5, Nexus 6, Samsung Galaxy
> 10e, etc.
> Does anybody have the same issue?
> PS: I didn't update to 4.11 because there are several things broken with
> CMake and AndroidDeployQt.

Hi Francesc,

what you write sounds like those report which might be duplicating each


I'm sad to say that nobody is maintaining Creator's Android integration
currently, so a fix might take a while.


More information about the Qt-creator mailing list