[Qtwebengine] open files

Andras Becsi andras.becsi at theqtcompany.com
Tue Jun 16 13:28:23 CEST 2015

Hi Tom,

You could try applying https://codereview.chromium.org/248193003
to the src/3rdparty/chromium snapshot, and see if that helps.


On 06/16/2015 01:19 PM, Andras Becsi wrote:
> Hi Tom,
> With an embedded device running X11 I do not think you can get much
> better performance, unless the device is really powerfull.
> To use ozone, you need a platform implementation, and we only provide it
> for eglfs (ozone_platform_eglfs.cpp). Also use_ozone=1 is probably
> conflicting with desktop_linux=1, and ozone_platform_dri is just an
> implementation of the ozone layer withing chromium, which won't work
> with Qt.
> As I wrote previously this setup is not supported hence not tested, so
> your crash is probably also caused by the heavy X11 setup.
> I'm not sure 60000 is even a valid value for ulimit, you could try
> setting a more realistic limit (ulimit -Sn 8192) according to:
> http://unix.stackexchange.com/questions/180063/chrome-too-many-files-open-crash-sorry-jim
>   > I also tried the pre-built 32-bit version of Qt 4.5.1
> You probably mean 5.4.1 here.
> For these kind of issues you can always google for Chromium problems
> since if you see something rendered by Qt and it runs, then the Qt layer
> basically works and the issue is most probably in the Chromium setup
> and/or the system setup, so other people might also encounter it.
> /Andras
> On 06/16/2015 12:59 PM, Tom Deblauwe wrote:
>> Hi,
>> Thanks Andras, I could compile it and I could run a simple webengineview
>> with the qmlscene application. I used the embedded_linux config, but
>> I've set these different:
>> use_x11=1
>> use_dbus=1
>> desktop_linux=1
>> use_ozone=0
>> Performance is not really great I must admit, but it works. The
>> animations and scrolling are sluggish. Is that maybe because of the
>> "use_ozone=0"? Maybe it would compile if I removed the
>> "ozone_platforms_dri=0" setting?
>> However, after a few page loads, i get a crash, indicating a "too many
>> open files" error. Setting the open files limit even as root with
>> "ulimit -n 60000" does not help. Maybe anybody has a clue about what
>> could be causing this and what your limits should be set to?
>> I also tried the pre-built 32-bit version of Qt 4.5.1 and there I have
>> the same "too many open files" problem, so it's very probably something
>> about my linux OS that is not correct, but how can I figure out what
>> exactly? Or a list of what webengine needs from the OS to run properly?
>> Best regards,
>> Tom,
>> _______________________________________________
>> QtWebEngine mailing list
>> QtWebEngine at qt-project.org
>> http://lists.qt-project.org/mailman/listinfo/qtwebengine
> _______________________________________________
> QtWebEngine mailing list
> QtWebEngine at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/qtwebengine

Best regards,
András Bécsi
Software Engineer | The Qt Company

The Qt Company AS
Sandakerveien 116
0484 Oslo, Norway

Mailing address:
PO Box 23 Nydalen
0410 Oslo, Norway

Visit us on: http://www.qt.io

More information about the QtWebEngine mailing list