[Qtwebengine] "qmake -r" error -- unknowm model: webchannel

Kevin Truong kevin at diffbot.com
Tue Nov 3 21:08:33 CET 2015

I don't know if this helps, but apparently I have both qt4 and qt5 plugins
installed, as well as qtchooser.

Here is the output of "make --version":
QMake version 3.0
Using Qt version 5.4.1 in /usr/lib/x86_64-linux-gnu

I installed Qt5 via sudo apt-get. I am guessing qt4 and qtchooser was
installed from the WebKitGtk+ installation scritps.

On Tue, Nov 3, 2015 at 11:41 AM, Kevin Truong <kevin at diffbot.com> wrote:

> Hi,
> I am trying to get qt webengine running on my laptop. I ran into some
> issues and would greatly appreciate any help. I am following the
> instructions from here:
> https://wiki.qt.io/QtWebEngineHowToTry
> On the last few steps, I had to run "qmake -r" on the qtwebengine
> directory. This is the output:
> SSL............................... Using system NSS
> ICU............................... Using internal copy (Default, force
> system ICU with WEBENGINE_CONFIG += use_system_icu)
> FFMPEG............................ Using internal copy (Default, force
> system FFMPEG with WEBENGINE_CONFIG += use_system_ffmpeg)
> Proprietary codecs (H264, MP3).... Not enabled         (Default, enable
> with WEBENGINE_CONFIG += use_proprietary_codecs)
> Reading /home/kevin/workspace/qtwebengine/src/src.pro
>  Reading /home/kevin/workspace/qtwebengine/src/core/core.pro
>   Reading /home/kevin/workspace/qtwebengine/src/core/
> core_gyp_generator.pro
> Project ERROR: Unknown module(s) in QT: webchannel
> This error happened right after I installed WebKitGtk+ from here (
> http://trac.webkit.org/wiki/BuildingGtk) and ran "Tools/gtk/install-dependencies"
> and "Tools/Scripts/update-webkitgtk-libs".
> (I installed WebKitGtk+ because, previously, running "qmake -r" on the
> qtwebengine directly resulted in an "unmet dependency: harfbuzz" error that
> I tried to fix on my own via google, and the WebKitGtk+ page was the only
> lead I could find that would supposedly fix that issue).
> I am running on a (mostly freshly reformatted) Ubuntu 15.04 laptop.
> Any help would be greatly appreciated! I would love to try out qt
> webengine.
> Thank you for your time,
> Kevin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qtwebengine/attachments/20151103/48706040/attachment.html>

More information about the QtWebEngine mailing list