[Development] Compiling for iOS, qtdeclarative and others fail

Ariel Molina ariel at edis.mx
Sat May 23 05:03:29 CEST 2015


I solved the problem, just want to share,

On Wed, May 20, 2015 at 12:16 PM, Edward Sutton <edward.sutton at subsite.com>

>  I understand the config commands used to build Qt packages are here:
>  http://code.qt.io/cgit/qtsdk/qtsdk.git/tree/packaging-tools/bld_config
I just followed your suggestion but using opensource [1], please Have a
look at my configure output [2].

It installed on /usr/local

   1. make -j8, took two hours, went OK
   2. cd qtbase,  sudo make install, OK
   3. cd qtimageformats, sudo make install, OK
   4. cd qtquick1, sudo make install, OK
   5. cd qtquickcontrols, sudo make install OK
   6. cd qtdeclarative, FAILS: http://i.imgur.com/QOAaEgJ.png

The error is:
Debug ===*
Check dependencies
Code Sign error: No provisioning profiles found: No non–expired
provisioning profiles were found.
CodeSign error: code signing is required for product type 'Application' in
SDK 'iOS 8.3'

Just out of curiosity I went into these (in exact order)

   - qtxmlpatterns, FAILS with same error
   - qtmultimedia, qtgraphicaleffects, qtsensors, qtsvg, qtcanvas3d,
   qtlocation, qtwebchannel, qtwebsockets, qt3d, OK

However I found a fix, I went into qt/xmlpatterns/tools/xmlpatterns and did
a normal non-sudo make, and it found my developer credentials. There, make
install worked. But not on the parent, qtxmlpatterns.

So the fix i implemented is I went into /usr/local and changed ownership of
Qt-5* to my user, then did all installs without sudo, then it finds my
Apple Developer credentials, it installs cleanly. Problem solved :)

Thank you for your time!


[2] http://pastebin.com/83vtcLzH
[3] Fails snapshot: http://i.imgur.com/QOAaEgJ.png
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/development/attachments/20150522/e600d20e/attachment.html>

More information about the Development mailing list