[Development] Compiling for iOS, qtdeclarative and others fail

Ziller Eike Eike.Ziller at theqtcompany.com
Tue May 26 08:59:12 CEST 2015

> On May 23, 2015, at 05:03, Ariel Molina <ariel at edis.mx> wrote:
> Hi, 
> I solved the problem, just want to share,
> On Wed, May 20, 2015 at 12:16 PM, Edward Sutton <edward.sutton at subsite.com> wrote:
> I understand the config commands used to build Qt packages are here:
> http://code.qt.io/cgit/qtsdk/qtsdk.git/tree/packaging-tools/bld_config
> I just followed your suggestion but using opensource [1], please Have a look at my configure output [2].
> It installed on /usr/local
> 	• make -j8, took two hours, went OK
> 	• cd qtbase,  sudo make install, OK
> 	• cd qtimageformats, sudo make install, OK
> 	• cd qtquick1, sudo make install, OK
> 	• cd qtquickcontrols, sudo make install OK
> 	• cd qtdeclarative, FAILS: http://i.imgur.com/QOAaEgJ.png
> The error is:
> === BUILD TARGET xmlpatterns OF PROJECT xmlpatterns WITH CONFIGURATION Debug ===
> Check dependencies
> Code Sign error: No provisioning profiles found: No non–expired provisioning profiles were found.
> CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 8.3’

xmlpatterns module probably builds the “xmlpatterns” and “xmlpatternsvalidator” for the target environment (in your case iOS), and therefore tries to sign these applications.
Similar for “qml.app”.

> Just out of curiosity I went into these (in exact order)
> 	• qtxmlpatterns, FAILS with same error
> 	• qtmultimedia, qtgraphicaleffects, qtsensors, qtsvg, qtcanvas3d, qtlocation, qtwebchannel, qtwebsockets, qt3d, OK
> However I found a fix, I went into qt/xmlpatterns/tools/xmlpatterns

> and did a normal non-sudo make, and it found my developer credentials.

If you use sudo, the process is running as root, and root doesn’t have your “normal” user’s developer credentials installed of course.
Did you build Qt with a simple “make” (as normal user, without “install”) before you tried to install?

> There, make install worked. But not on the parent, qtxmlpatterns.
> So the fix i implemented is I went into /usr/local and changed ownership of Qt-5* to my user, then did all installs without sudo, then it finds my Apple Developer credentials, it installs cleanly. Problem solved :)
> Thank you for your time!
> Ariel
> [1] http://code.qt.io/cgit/qtsdk/qtsdk.git/tree/packaging-tools/bld_config/configure_ios_opensource
> [2] http://pastebin.com/83vtcLzH
> [3] Fails snapshot: http://i.imgur.com/QOAaEgJ.png
> _______________________________________________
> Development mailing list
> Development at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/development

Eike Ziller, Senior Software Engineer | The Qt Company
Digia Germany GmbH, Rudower Chaussee 13, D-12489 Berlin
Geschäftsführer: Mika Pälsi, Juha Varelius, Tuula Haataja
Sitz der Gesellschaft: Berlin, Registergericht: Amtsgericht Charlottenburg, HRB 144331 B

More information about the Development mailing list