[Development] Qt 5.14 MinGW debug build doesn't add debug suffix

Kai Köhne Kai.Koehne at qt.io
Tue Jan 14 09:02:01 CET 2020

> From: Development <development-bounces at qt-project.org> On Behalf Of Dmitriy Purgin
> Sent: Tuesday, January 14, 2020 8:46 AM
> To: Thiago Macieira <thiago.macieira at intel.com>
> Cc: Qt development mailing list <development at qt-project.org>
> Subject: Re: [Development] Qt 5.14 MinGW debug build doesn't add debug suffix
> I've just discovered another side-effect of this change. I've integrated the qdoc.exe in a custom toolchain for internal use, and it should be able to run in environments > without any Qt installations. So I used to do the windeployqt.exe on it, and it always worked until 5.14. Now windeployqt says that the qdoc.exe is a Debug executable > (!), and it fails to deploy Qt5Cored.dll for obvious reasons. It seems like windeployqt is broken as well. 

Can you file a bug about this? I’m still hoping to fix all remaining issues for 5.14.1 …
> I wonder what happens to debug-and-release builds now.

-debug-and-release was completely disabled in Qt 5.14.0, but will work again in Qt 5.14.1 (though still not be the default).


Thiago Macieira - thiago.macieira (AT) http://intel.com
  Software Architect - Intel System Software Products

Development mailing list
mailto:Development at qt-project.org

More information about the Development mailing list