[Interest] Qt Assistant can't search

David Ching dc at dcsoft.com
Tue Mar 13 21:55:34 CET 2012

>Date: Tue, 13 Mar 2012 13:21:56 -0700
>From: John Weeks <john at wavemetrics.com>
>Subject: [Interest] Qt Assistant can't search
>To: interest at qt-project.org
>Message-ID: <7A4BD766-DD20-4918-B57D-89D06E372AD6 at wavemetrics.com>
>Content-Type: text/plain; charset="us-ascii"
>I have recently installed Qt 4.8 on my Macintosh, and now Qt Assistant
can't search for anything. The documentation is clearly all there (I've been
reading it) but searches give a big "Your search did >not match any
documents." message. I even got that when I tried to search for "QWidget".
>I presume that it just needs to have its index re-built, but I can't seem
to figure out how to make that happen.
>I tried removing all the documentation sets and re-adding them, but it
doesn't make a difference.

I had that happen with Qt 4.7.4 on Windows.  I had to go into Qt Assistant's
Edit | Preferences | Documentation tab | Add button, and add all the .qch
files in the QtSdk/Documentation/ folder.

I think this is a bad bug that a freshly installed Qt doesn't show help
correctly, but thankfully it was an easy fix (after spending a few minutes
of CPU 'brain' time).

-- David

More information about the Interest mailing list