[Interest] Qt Assistant can't search

John Weeks john at wavemetrics.com
Wed Mar 14 01:01:52 CET 2012

Thanks, David. That's what I tried. I tried removing everything and adding it back. I tried removing everything, closing Qt Assitant, re-starting Assistant and adding everything back. I tried it more than once, and with some details thrown in like setting it to a blank page before removing everything. My search still doesn't work.

I'm wondering if there's an index file somewhere that I can trash in order to force the index to be re-built.

Or maybe there's a secret way to make Assistant rebuild its index.

-John Weeks

On 13-Mar-2012, at 1:55 PM, David Ching wrote:

>> Date: Tue, 13 Mar 2012 13:21:56 -0700
>> From: John Weeks <john at wavemetrics.com>
>> Subject: [Interest] Qt Assistant can't search
>> To: interest at qt-project.org
>> Message-ID: <7A4BD766-DD20-4918-B57D-89D06E372AD6 at wavemetrics.com>
>> Content-Type: text/plain; charset="us-ascii"
>> I have recently installed Qt 4.8 on my Macintosh, and now Qt Assistant
> can't search for anything. The documentation is clearly all there (I've been
> reading it) but searches give a big "Your search did >not match any
> documents." message. I even got that when I tried to search for "QWidget".
> Huh.
>> I presume that it just needs to have its index re-built, but I can't seem
> to figure out how to make that happen.
>> I tried removing all the documentation sets and re-adding them, but it
> doesn't make a difference.
> I had that happen with Qt 4.7.4 on Windows.  I had to go into Qt Assistant's
> Edit | Preferences | Documentation tab | Add button, and add all the .qch
> files in the QtSdk/Documentation/ folder.
> I think this is a bad bug that a freshly installed Qt doesn't show help
> correctly, but thankfully it was an easy fix (after spending a few minutes
> of CPU 'brain' time).
> -- David
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/interest

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20120313/93fe0b65/attachment.html>

More information about the Interest mailing list