[Interest] [Mingw-w64-public] Not getting large file support when configuring Qt 4.8.4 for win32-g++-4.6

K. Frank kfrank29.c at gmail.com
Mon Apr 15 01:31:19 CEST 2013

Hi Jon!

On Sun, Apr 14, 2013 at 6:11 PM, JonY <> wrote:
> On 4/15/2013 00:46, K. Frank wrote:
>> Hello Lists!
>> I'm am building Qt 4.8.4 with mingw-w64 4.8.1 on a 64-bit windows 7 machine.
>> (Specifically, qt-everywhere-opensource-src-4.8.4.zip and
>> x86_64-w64-mingw32-gcc-4.8-stdthread-win64_rubenvb.7z, downloaded
>> recently.)
>> When I run configure, specifying "-platform win32-g++-4.6", but not specifying
>> anything about large file support one way or the other, it seems that large file
>> support is turned off.  The output form configure contains:
>>    Large File support..........no
>> I am under the impression that configure is supposed to turn on large file
>> support, based on auto-detected capabilities of the system in question.
>> One thought that crossed my mind is that maybe 64-bit mingw-w64 no
>> longer needs special large file support turned on, in that it always has
>> is, but I couldn't find any commentary to this effect.
>> Maybe I'm wrong about configure auto-detecting large file support, and I
>> need to specify it manually.
>> Or maybe my system is messed up somehow.
>> Thanks for any advice.
> Is there some sort of log? Hard to tell what configure did to test
> without it.

First, I don't know whether configure does a test.  I saw some online
comments that suggest it does, but nothing definitive.

Second, I don't see anything that looks like a log of tests run by
configure.  (But I certainly don't know where to look.)

Third, the online qt documentation for configure I found was silent
on large file support.

Fourth, running "configure --help" reports:

   -largefile ......... Enables Qt to access files larger than 4 GB.

with the -largefile argument not being flagged with a "*" (default) or
a "+" (an "evaluated" default).  So taking this at face value, large
file support is off by default.

Fifth -- and here's where it gets annoying -- I cleaned everything
out and re-ran configure with "-largefile" specified.  Now configure
claimed that large file support was turned on.  So far so good.

But when I ran the build, I got many copies of the following warning:

warning: "QT_LARGEFILE_SUPPORT" redefined [enabled by default]
   <command-line>:0:0: note: this is the location of the previous definition

And, indeed, the g++ compile command run by the build does


I guess things are running correctly and these are just annoying
warnings.  But it makes me think that the "correct" thing to have
done would have been to run configure without -largefile, hopefully
shutting up all the warnings, but having large file support enabled

Do any Qt experts know what is going on here?  What's the "right"
way to build Qt to get large file support?

I'm suspecting that this is a Qt issue, and not specific to mingw-w64.
But I'll take the liberty of leaving it cross-posted to the mingw64 list
for the time being.


K. Frank

More information about the Interest mailing list