[Interest] Can't run Qt application under UWP kit

Alexander Dyagilev alervdvcw at gmail.com
Tue Jan 24 08:37:22 CET 2017


My app is Qt Quick Controls 2 based app. Qt 5.7.1, Windows 10, Visual 
Studio 2015.

Desktop 32bit version works fine.

But when I switch to *Qt 5.7.1 for Universal Windows Platform 32bit* 
kit, it fails to run with the following error:

|winrtrunner --device 0--start --stop --install --wait 0--profile appx 
qt.winrtrunner:Usingthe Appxprofile.qt.winrtrunner:Failedto activate 
application:0x8027025b"The app didn't start."Errorwhileexecuting the 

It states here 
<https://forum.qt.io/topic/50638/start-application-on-winrt> that some 
dependency is missing. I've checked it using Dependency Walker and it 
seems that all the required DLLs are in the application's folder. I've 
also tried to copy just all the files from Qt kit installation into 
app's dir.

My application consists of one main executable and three .DLL files. 
I've launched windeployqt for the each of them. Tried both debug and 
release versions.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20170124/e84d53c1/attachment.html>

More information about the Interest mailing list