[Interest] QWebEngineView + QSurfaceFormat == errors in console

Andy asmaloney at gmail.com
Fri May 5 18:12:49 CEST 2017


Thanks Sean.

One of the problems is likely that I'm using Qt3DWindow which calls
QSurfaceFormat::setDefaultFormat() in the constructor which I've already
called in main(). I'd missed this warning in my application's output
because I have a bunch of debug output:

Warning: Warning: Setting a new default format with a different version or
profile after the global shared context is created may cause issues with
context sharing. (qsurfaceformat.cpp:770, static void
QSurfaceFormat::setDefaultFormat(const QSurfaceFormat &))

The docs say that setDefaultFormat() needs to be called before the
QGuiApplication is constructed if Qt::AA_ShareOpenGLContexts is set.

So it seems like Qt3DWindow shouldn't be setting the default format? Or
documented that it's not usable with a shared context?

---
Andy Maloney  //  https://asmaloney.com
twitter ~ @asmaloney <https://twitter.com/asmaloney>


On Fri, May 5, 2017 at 3:29 AM, Sean Harmer <sean.harmer at kdab.com> wrote:

> On Thursday 04 May 2017 17:57:32 Thiago Macieira wrote:
> > Em quinta-feira, 4 de maio de 2017, às 16:07:12 PDT, Andy escreveu:
> > > Fatal: QWebEngine: Default QSurfaceFormat OpenGL profile is not
> compatible
> > > with the global shared context OpenGL profile. Please make sure you
> set a
> > > compatible QSurfaceFormat before the QtGui application instance is
> > > created.    (render_widget_host_view_qt_delegate_widget.cpp:148,
> > > QtWebEngineCore::RenderWidgetHostViewQtDelegate
> Widget::RenderWidgetHostVie
> > > wQ tDelegateWidget(QtWebEngineCore::RenderWidgetHostViewQtDelegate
> Client
> > > *, QWidget *))
> > >
> > > (Setting the default QSurfaceFormat is the very first thing I do in
> main.)
> >
> > Looks like the Qt3D and QtWebEngine requirements for the OpenGL profile
> are
> > incompatible.
>
> Qt 3D will work with any context, compatibility or profile for modern GL
> or no
> profile for legacy GL. I assume that you actually need some GL 4.1
> features if
> that's what you're asking for. It seems like the QtWebEngine check on GL
> version/profile is broken as the compatibility profile should be, well,
> compatible with legacy GL.
>
> Cheers,
>
> Sean
>
> --
> Dr Sean Harmer | sean.harmer at kdab.com | Managing Director UK
> KDAB (UK) Ltd, a KDAB Group company
> Tel. +44 (0)1625 809908; Sweden (HQ) +46-563-540090
> Mobile: +44 (0)7545 140604
> KDAB - Qt Experts
> _______________________________________________
> Interest mailing list
> Interest at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/interest
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20170505/b4afab6e/attachment.html>


More information about the Interest mailing list