[Interest] Qt 5.9 and OpenSSL 1.1?

maitai maitai at virtual-winds.org
Fri Mar 22 21:02:57 CET 2019


Interesting exchange but can someone summarize?

I distribute an app compiled with qt 5.11.1, and I cannot go immediately 
to 5.12

I deliver the libs for ssl 1.0 a bit the way creator is doing it.

It works in 99% of the cases, but some rare linux distributions just 
crash.

The solution would be to compile qt myself with ssl support 1.0 or 1.1, 
something I refuse to do since I am already doing that too much 
(raspberry, 32 bits distribs, etc). Not mentioning that most users will 
be really confused with the question "are you using ssl 1.0.x or 1.1.x 
?"

Ideally qt should be compatible for both. I understand this is not 
doable ?

At least deliver binaries for both, please.

Philippe (commercial license, if that matters).

Le 22-03-2019 19:41, Thiago Macieira a écrit :
> On Friday, 22 March 2019 10:46:28 PDT René J. V. Bertin wrote:
>> Could make it risky to use their patch, if they don't take particular 
>> care
>> for the OpenSSL 1.0 paths.
> 
> Right. But why are you interested in supporting both? If your systems 
> have
> OpenSSL 1.1, use that.
> 
> If you haven't upgraded OpenSSL yet, use stock 5.9.


More information about the Interest mailing list