[Interest] Trouble compiling qt3d for qt6 on windows 10

Daniel Patel danielpatel.no at gmail.com
Tue Feb 16 13:33:27 CET 2021

Thanks a lot for the reply Paul, it was useful as always.
Copying the files made the qt3d examples work!
I realized that the compile error showed up because qt6 itself was only
compiled in debug mode.
With the appropriate flag to the configure script, qt6 now compiles both in
debug and in release.

However, now when compiling qt3d I ran into the error : "Could not find
feature qt3d-simd-avx2" (I already configured and compiled qt6 with -avx2
I am just not able to tell/configure qt3d to use avx2 instead of sse2.
Currently "qmake .." returns:
  Use SSE2 instructions .................. yes

  Use AVX2 instructions .................. no

After running configure for the qt6 build I got this text as output:
"To configure and build other Qt modules, you can use the following
convenience script:
So i did a "c:\Qt\Qt-6.1\bin\qt-configure-module.bat
qt3d-everywhere-src-6.0.0 --qt3d-simd=avx2"   but that failed with
"Unknown command line option '--qt3d-simd=avx2'"  (I also tried
-avx2-qt3d-simd and -qt3d-simd-avx2)
Anyone knows how to set configure flags for qt3d before compiling it?

On a side note I also was not able to get qt6 configure script to detect
zlib libraries even though I set appropriate environment variables and sent
in paths using both -D option as well as -I and -L option.

man. 15. feb. 2021 kl. 11:47 skrev Paul Lemire <paul.lemire at kdab.com>:

> I can't really help about the compile issues. But I should be able to help
> regarding the plugin error.
> You likely need to copy a few more things from the qt3d build dir to your
> Qt install dir:
> qt3d_build_dir/qml/Qt3D into Qt_Install_Dir/qml/
> qt3d_build_dir/qml/QtQuick/* into Qt_Install_Dir/qml/QtQuick/
> qt3d_build_dir/plugins/* into Qt_Install_Dir/plugins/
> (the plugins dir contains a renderers folder which contains the Qt3D
> render plugins)
> I hope that helps,
> Paul
> On 2/15/21 11:03 AM, Daniel Patel wrote:
> I have compiled qt6.1 from source which works and now I am trying to
> compile qt3d also from source by downloading from
> https://download.qt.io/official_releases/additional_libraries/qt3d/6.0/6.0.0/
> and following the qmake instructions from:
> https://www.kdab.com/getting-your-3d-ready-for-qt-6/
> I first tried to download and compile qt3d-everywhere-src-6.0.1 but got an
> error about missing zlib.h. Instead of trying to fix this I quickly instead
> tried with qt3d-everywhere-src-6.0.0 and this compiled fine.
> However it only compiled debug dlls and not release dlls. I tried to do
> nmake all and nmake release but the latter gave the error "NMAKE : fatal
> error U1073: don't know how to make
> 'C:\qtsrc\qt61\qt5\qtbase\lib\Qt6Gui.lib'"
> I then decided to try out the debug build. First I noticed that the qt3d
> dlls didnt seem to have been copied over to the correct folder when I did
> nmake install. So I copied them over manually and then started
> basicshapes-cpp.exe, but this showed the runtime error: Unable to find
> renderer plugin for opengl.
> Any hints for what to do?
> Best
> Daniel
> _______________________________________________
> Interest mailing listInterest at qt-project.orghttps://lists.qt-project.org/listinfo/interest
> --
> Paul Lemire | paul.lemire at kdab.com | Senior Software Engineer
> KDAB (France) S.A.S., a KDAB Group company
> Tel: France +33 (0)4 90 84 08 53, http://www.kdab.fr
> KDAB - The Qt, C++ and OpenGL Experts
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20210216/6ecd9cdc/attachment.html>

More information about the Interest mailing list