[PySide] help: can't install Pyside on linux anymore

Frank Rueter | OHUfx frank at ohufx.com
Thu Aug 29 08:22:17 CEST 2013

Hi guys,

this may be a linux problem more than a PySide problem, but after a day 
of searching for a solution I am a bit desperate and was hoping somebody 
here would be able to help:

A few days ago I installed PySide on Kubuntu 12.10 without any trouble 
by running those commands:

|sudo add-apt-repository ppa:pyside
sudo apt-get update
sudo apt-get install python-pyside|

This successfully installed PySide to 

I then decided to move the installed PySide folder to a central server 
location which is in my PYTHONPATH to be able to access the same PySide 
install from multiple machine (to avoid version problems etc).

After that some host applications that are using PySide natively 
wouldn't launch any longer (PySide itself worked fine), so I decided to 
back paddle; I deleted all files on the server again and ran this to 
clean up:
sudo apt-get purge python-pyside|
|sudo apt-get autoremove

Now I thought I'd be ready for a clean install again, so I started over 
with the above mentioned install commands.
First, this only installed the binaries (.so files) into 
/usr/lib/python2.7/dist-packages/PySide, no __init__.py, nothing else.
So I tried un-installing and re-installing a few times, but now nothing 
gets installed at all anymore.

When running |sudo apt-get update|, I now get these errors:

    /Err http://ppa.launchpad.net quantal/main Sources 404  Not Found//
    //Hit http://security.ubuntu.com quantal-security/restricted i386
    //Err http://ppa.launchpad.net quantal/main amd64 Packages 404  Not
    //Err http://ppa.launchpad.net quantal/main i386 Packages 404  Not
    //W: Failed to fetch
    404  Not Found//
    //W: Failed to fetch
    404  Not Found//
    //W: Failed to fetch
    404  Not Found/

I checked in a web browser, and sure enough, the "quantal" dist does not 

It feels like it was simply removed the other day since I was able to 
install PySide successfully but it's more likely that I'm stuffing up 
something here.

Can somebody please help with this? I am stuck and need to get this 
running soon :(

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/pyside/attachments/20130829/2522896d/attachment.html>

More information about the PySide mailing list