[PySide] help: can't install Pyside on linux anymore

Tibold Kandrai kandraitibold at gmail.com
Thu Aug 29 11:36:36 CEST 2013

Hey Frank,

If the ppa doesn’t exist, you could try to compile it yourself or by manually downloading it or by installing from PyPi with:

sudo pip install PySide

There are a few dependencies you need to have installed like CMake, but the build will let you know what does it need. I just had to build it myself too as for OS X there are no 1.2.1 binaries available.

In my case the only problem I had with it is that the Ui tools didn’t build, but since I’m not really using it that’s not that big of a problem for me, although they can be compiled by fixing the cmake files.


Tibold Kandrai

From: Frank Rueter | OHUfx
Sent: ‎Thursday‎, ‎29‎ ‎August‎ ‎2013 ‎09‎:‎09
To: pyside at qt-project.org

Thanks for the heads up Sebastian.
That is probably a good way to go, as I need to add os specific logic as well (I am in a mixed linux and osx environment).

For now, I'm just trying to get the vanilla install to work again though.
And then get my head back into PySide which I was forced to neglect for almost a year.

Hope all is well in Berlin!


On 29/08/13 19:03, Sebastian Elsner wrote:

Hey Frank,

I don't know about the linux part but you can keep PySide on a central server, just don't add that path to you PYTHONPATH by default. Nuke does not need to know about it, but in a standalone app you could just do something like:

import sys

and that one works again. 

The strategy I am going for here is: All standalone apps use the standard (Windows) Python and standard installers for packages. 
We have a lot of compiled dependencies  like PyQt, ZeroMQ or MySQL in Maya/Nuke/Houdini. The path.add method is the way I manage those to dynamically "mount" (i.e. path.add) all the packages I need per host program (with their own compiler version, because thats where the problem comes from)



 placeOn 08/29/2013 08:22 AM, Frank Rueter | OHUfx wrote:

Hi guys,

this may be a linux problem more than a PySide problem, but after a day of searching for a solution I am a bit desperate and was hoping somebody here would be able to help:

A few days ago I installed PySide on Kubuntu 12.10 without any trouble by running those commands:
sudo add-apt-repository ppa:pyside
sudo apt-get update
sudo apt-get install python-pyside

This successfully installed PySide to /usr/lib/python2.7/dist-packages/PySide

I then decided to move the installed PySide folder to a central server location which is in my PYTHONPATH to be able to access the same PySide install from multiple machine (to avoid version problems etc).

After that some host applications that are using PySide natively wouldn't launch any longer (PySide itself worked fine), so I decided to back paddle; I deleted all files on the server again and ran this to clean up:

sudo apt-get purge python-pyside
sudo apt-get autoremove

Now I thought I'd be ready for a clean install again, so I started over with the above mentioned install commands.
First, this only installed the binaries (.so files) into /usr/lib/python2.7/dist-packages/PySide, no __init__.py, nothing else.
So I tried un-installing and re-installing a few times, but now nothing gets installed at all anymore.

When running sudo apt-get update, I now get these errors:

Err http://ppa.launchpad.net quantal/main Sources  404  Not Found
Hit http://security.ubuntu.com quantal-security/restricted i386 Packages
Err http://ppa.launchpad.net quantal/main amd64 Packages  404  Not Found
Err http://ppa.launchpad.net quantal/main i386 Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/pyside/ppa/ubuntu/dists/quantal/main/source/Sources  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/pyside/ppa/ubuntu/dists/quantal/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/pyside/ppa/ubuntu/dists/quantal/main/binary-i386/Packages  404  Not Found

I checked in a web browser, and sure enough, the "quantal" dist does not exist:

It feels like it was simply removed the other day since I was able to install PySide successfully but it's more likely that I'm stuffing up something here.

Can somebody please help with this? I am stuck and need to get this running soon :(


PySide mailing list
PySide at qt-project.org

check out www.pointcloud9.com

Sebastian Elsner - Pipeline Technical Director - RISE

t: +49 30 20180300 florian at risefx.com
f: +49 30 61651074 www.risefx.com

Schlesische Strasse 28, Aufgang B, 10997 Berlin
c/o action concept, An der Hasenkaule 1-7, 50354 Hürth
Geschaeftsfuehrer: Sven Pannicke, Robert Pinnow
Handelsregister Berlin HRB 106667 B

PySide mailing list
PySide at qt-project.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/pyside/attachments/20130829/c6cec3ca/attachment.html>

More information about the PySide mailing list