[PySide] trouble with special characters in widget.setToolTip()

Tim Roberts timr at probo.com
Wed Mar 2 18:26:20 CET 2016

Sebastian Elsner | RISE wrote:
> Unicode is tricky, it bites me every time. This works:

It's not that hard.  There are two possibilities.  Either the setTool
function does not accept Unicode strings, or the default tool tip font
does not include those extended characters.

> Please note, the .py file actually has to be saved/encoded as utf-8.
> You need to do this via your editor's save/convert function.

Actually, it doesn't.  There are no characters in his file beyond the
base ASCII set, except for the one character in a comment, so the file
coding is irrelevant.  If this worked for you, then his original code
would have worked for you also.  That would imply that your tooltip uses
a different default font.  No one here has mentioned what operating
systems they are using; that makes a difference.

Tim Roberts, timr at probo.com
Providenza & Boekelheide, Inc.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/pyside/attachments/20160302/a6c8a9b4/attachment.html>

More information about the PySide mailing list