[PySide] trouble with special characters in widget.setToolTip()

Frank Rueter | OHUfx frank at ohufx.com
Thu Mar 3 01:45:01 CET 2016

Thanks guys.

 >>That would imply that your tooltip uses a different default font.
Aha, that makes perfect sense, thank you!
I'm currently on OSX using Wing as my IDE. When I ran this code inside a 
host application, it worked fine (because it changes the default font).
I will verify that though before moving on. Text encoding/decoding 
always confuses me (I hardly have to deal with it, so there is no 
routine) and I want to get it right this time.


On 03/03/2016 06:26 AM, Tim Roberts wrote:
> Sebastian Elsner | RISE wrote:
>> Unicode is tricky, it bites me every time. This works:
> It's not that hard.  There are two possibilities.  Either the setTool 
> function does not accept Unicode strings, or the default tool tip font 
> does not include those extended characters.
>> Please note, the .py file actually has to be saved/encoded as utf-8. 
>> You need to do this via your editor's save/convert function.
> Actually, it doesn't.  There are no characters in his file beyond the 
> base ASCII set, except for the one character in a comment, so the file 
> coding is irrelevant.  If this worked for you, then his original code 
> would have worked for you also.  That would imply that your tooltip 
> uses a different default font.  No one here has mentioned what 
> operating systems they are using; that makes a difference.
> -- 
> Tim Roberts,timr at probo.com
> Providenza & Boekelheide, Inc.
> _______________________________________________
> PySide mailing list
> PySide at qt-project.org
> http://lists.qt-project.org/mailman/listinfo/pyside

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/pyside/attachments/20160303/0e3056c7/attachment.html>

More information about the PySide mailing list