[Qt-creator] QtCreator crashes when trying to debug STM32 bare metal device

Axel Jäger axeljaeger at googlemail.com
Sun Aug 31 20:12:39 CEST 2014


I got once debugging a STM32 board with the bare metal plugin in QtC working
on my mac. Unfortunately, I do not now the exact version of QtC then.


I tried to reproduce the behavior now I have problems to start such a debug
session with QtC 3.1.2 again.

-          When trying to flash the target, everything seems fine, I see a
lot of messages in the st-util that look promising

-          After that, the debug session does not start. Trying to pause
execution or setting a breakpoint crashes the QtCreator

Note that after manually resetting the target, the uploaded programm runs
fine without the debugger, so flashing the target seems to work properly.


The behaviour was reproduced on a mac and on a windows machine. In both
cases, the compiler from the arm-toolchain from launchpad was used from



GDB was recompiled on both cases to have python support. I had no success
with the makefile in the QtC-repo but thats another story.


Tim Sander gave me tip that synchronous debugging might be broken in the
current release and that I should try async debugging. I tried adding „set
target-async on“ to my gdb startup in QtCreator but this seems to not change


Is this a known issue? Does anybody observed similar behaviour? Does anybody
know a workaround?


Best regards,


Axel Jäger

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/qt-creator/attachments/20140831/7c1c875c/attachment.html>

More information about the Qt-creator mailing list