[Interest] Interest Digest, Vol 68, Issue 13

Roland Hughes roland at logikalsolutions.com
Sat May 20 00:17:22 CEST 2017

On 05/18/2017 08:31 AM, Kevin Funk wrote:
> Citing you from the thread:
>> ...
>> No, KDevelop does things completely different from Qt so not an
>> option...
>> ...
> KDevelop is an IDE, Qt is an application development framework. So in fact
> your relation cannot make sense to begin with.
Qt is an application framework with a design and build philosophy of 
.pro, qmake and moc. Every book I have seen on development with Qt, 
including my own <http://theminimumyouneedtoknow.com/> adheres to the 
path. KDevelop never used to which is why I excluded it from this book 
<http://theminimumyouneedtoknow.com/qt_book.html> which covered 
QtCreator, Monkey Studio, QDevelop and Eclipse using the Qt plug-in.

As it stands I did install KDevelop and attempted to use it. Still not 
an option at least as far as I can determine. Technically it is an IDE, 
but, it doesn't have access to the Designer _and_ the designer isn't in 
its own installation package _and_ as other messages in this list have 
pointed out, unless you build all of Qt from source you cannot really 
build the Designer. You can do a lot of hacking to get QtCreator to 
build, but, once again, will not have a designer.

Yes, I have built Qt from source probably more than a hundred times. 
This particular machine has repo kits installed and I don't wish to try 
backing them out because I find they never quite remove everything and 
at this point I do not feel compelled to do a clean wipe with fresh 
spartan install.

Most likely my experience with KDevelop pre-dates yours. My first 
exposures to it was back when it supported every language anyone could 
think of. It came with a monolithic build environment which had to be 
pulled down and installed to do practically anything. Putting this time 
frame in perspective for everyone:

  * SuSE didn't have "open" in front of it. You paid $90 and got a box
    shipped to you which had some floppies and a printed manual. You
    then had to maintain a dial-up connection for hours to pull down
    everything SuSE insisted on installing. RPM was (and probably still
    is) absolutely worthless when it comes to lost dial-up connection
    mid installation. When one needed to utilize KDevelop it meant many
    more hours of dial-up.
  * OS/2 Warp was still in wide use on ATMs and several major IBM
    customers like Sears.
  * Only a tiny few markets had the option of cable Internet access.
  * They were called "car phones" not "cell phones" or "mobile phones"
    because they were installed into cars. There were only a few
    "luggable" phones, one of which was a Panasonic "boat phone" which I
    owned but cannot find a picture of now.

That was the era when I first ventured into KDevelop. It was at the tail 
end of the Zinc Application Framework (ZAF) 
<https://en.wikipedia.org/wiki/Zinc_Application_Framework> era after 
Wind River bought it for their own OS and Qt was just venturing out of 
the womb. I was forced to use KDevelop a few times after that and moving 
from a stand alone build to something which worked inside of KDevelop 
always involved great pain. Perhaps a large part of that pain was making 
the app fit into a KDE build. Been long time.

Personally I was shocked to see both COBOL and FORTRAN were dropped from 
KDevelop since there is an incredibly large payroll processor using 
COBOL on Linux and Unix as well as a few others using quite a bit of 
FORTRAN, but that is different tale.

> Please don't do sweeping attacks (citing "qtcreator is broken", "KDE crowd
> used to be so adamant about keeping 'their' process") without explanation and
> proofs.
Please don't scope quotes. I said qtcreator is broken on KDE Neon 5.8.6 
which is true as others on this list have pointed out.

roland at roland-HP-Compaq-8100-Elite-SFF-PC:~$ sudo apt install qtcreator

[sudo] password for roland:

Reading package lists... Done

Building dependency tree

Reading state information... Done

Starting pkgProblemResolver with broken count: 1

Starting 2 pkgProblemResolver with broken count: 1

Investigating (0) qtcreator [ amd64 ] < none -> 3.5.1+dfsg-2ubuntu2 > ( universe/devel )

*Broken*  qtcreator:amd64 Depends on qtcreator-data [ amd64 ] < none -> 3.5.1+dfsg-2ubuntu2 > ( universe/devel ) (= 3.5.1+dfsg-2ubuntu2)

   Considering qtcreator-data:amd64 0 as a solution to qtcreator:amd64 9999

   Re-Instated qtcreator-data:amd64

*Broken*  qtcreator:amd64 Depends on libbotan-1.10-1 [ amd64 ] < none -> 1.10.12-1 > ( universe/libs ) (>= 1.10.10)

   Considering libbotan-1.10-1:amd64 0 as a solution to qtcreator:amd64 9999

   Re-Instated libbotan-1.10-1:amd64

*Broken*  qtcreator:amd64 Depends on libclang1-3.6 [ amd64 ] < none -> 1:3.6.2-3ubuntu2 > ( devel ) (>= 3.6)

   Considering libclang1-3.6:amd64 0 as a solution to qtcreator:amd64 9999

   Re-Instated libllvm3.6v5:amd64

   Re-Instated libclang1-3.6:amd64

*Broken *qtcreator:amd64 Depends on libqbscore1 [ amd64 ] < none -> 1.4.5+dfsg-2 > ( universe/libs ) (>= 1.4.1)

   Considering libqbscore1:amd64 0 as a solution to qtcreator:amd64 9999

   Re-Instated libqbscore1:amd64

*Broken*  qtcreator:amd64 Depends on libqbsqtprofilesetup1 [ amd64 ] < none -> 1.4.5+dfsg-2 > ( universe/libs ) (>= 1.2.1)

   Considering libqbsqtprofilesetup1:amd64 0 as a solution to qtcreator:amd64 9999

   Re-Instated libqbsqtprofilesetup1:amd64

*Broken*  qtcreator:amd64 Depends on qtbase-abi-5-5-1 [ amd64 ] < none ->  > ( none )

   Considering libqt5core5a:amd64 3187 as a solution to qtcreator:amd64 9999

   Considering libqt5core5a:amd64 3187 as a solution to qtcreator:amd64 9999

*Broken*  qtcreator:amd64 Depends on qtdeclarative-abi-5-5-0 [ amd64 ] < none ->  > ( none )

   Considering libqt5qml5:amd64 405 as a solution to qtcreator:amd64 9999


Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

  qtcreator : Depends: qtbase-abi-5-5-1

              Depends: qtdeclarative-abi-5-5-0

              Recommends: qtcreator-doc but it is not going to be installed

              Recommends: qtxmlpatterns5-dev-tools

E: Unable to correct problems, you have held broken packages.

Roland Hughes, President
Logikal Solutions


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.qt-project.org/pipermail/interest/attachments/20170519/86cb92d5/attachment.html>

More information about the Interest mailing list